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1 Web License 
Overview, Set Up 
and Management

The information in this chapter is arranged into the following 
main topics:

• Kurzweil 3000 Web License Overview on page 2.

• Web License System Requirements on page 5.

• Installing Web License Client Software on page 6.

• Installing the Web License Client Using the MSI Install (IT 
Professionals) on page 7.

• Working with User Accounts and License Allocation on page 8.
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Kurzweil 3000 Web License Overview
Kurzweil 3000 Web License Overview
Welcome to Kurzweil 3000  Web License Edition. If you are a Web License 
user, you can access all of the program’s features from any computer that 
has Internet connection and that is running the Web License Client software. 

Kurzweil 3000 maintains personal settings, documents and work, even if you 
switch computers or go wireless.

Licenses for Using Kurzweil 3000 Over the Internet

Kurzweil 3000 Web License product offers convenient, secure Kurzweil 3000 
license check in/out through the Web.

Unlike Network Edition licenses, the storage and management of which are 
on the local network, Web licenses are stored and managed by Cambium 
Learning and delivered to users over the Internet. 

In addition to placing less of a burden on a school’s technology team, Web 
Licensing allows users to access licenses and run Kurzweil 3000 from any 
computer on which the Kurzweil 3000 Web License Client software is 
installed, and from anywhere on the Internet, while taking personal settings 
and preferences with them.

Web License Users

There are three types of users: 

• Designated License Coordinator who is set up by Cambium Learning for 
the organization. This user has the ability to create and manage sub-
users and to allot licenses to those sub-users, which can include Student 
users. When viewing user information, this user can see and change all 
of his/her sub-users’ information. When viewing Universal Library 
contents, this user can access all of his/her sub-users’ folders.

• Site coordinator who could be a teacher, principal, or other school 
authority. Set up by the organization’s license coordinator, this user has 
the ability to create and manage sub-users, including Student users, and 
to allot licenses to those sub-users. When viewing user information, the 
site coordinator/teacher user can see and change all of his/her sub-
users’ information. When viewing Universal Library contents, this user 
can access all of his/her sub-users’ folders.
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Chapter 1. Web License Overview, Set Up and Management
• Student users are created and registered by any user who can create 
sub-users. They cannot, however, have sub-users, nor have access 
other users’ folders in the Universal Library except Public ones created 
by their teachers or for the organization.

Complemented by Web-Based Universal Library 

Included with the Kurzweil 3000 Web License Edition is the Web Universal 
Library, a robust file repository that provides leveled access to files and 
documents. 

The Web Universal Library enables districts or schools to widely distribute 
curriculum, and share and reuse material. Any user can upload district-wide 
curriculum and resource files. Teachers are able to post classwork, and 
students can access those files and documents from anywhere on the 
Internet, from any Kurzweil 3000 Web Client computer, at any time.

The Web License Universal Library also includes the Classic Literature 
collection of nearly 2000 public domain electronic text, from literary classics, 
factbooks, and references to religious and historical documents.

For additional details about the Web Universal Library, see Chapter 2, Web 
Universal Library.

All Preferences, Customized Lists, Dictionaries and Settings Travel 
with the User

Kurzweil 3000 Web License system maintains each user’s personal 
preferences, settings and any feature that is customizable, including Toolbar 
sets, Word Lists, OCR Corrections list, and Word Prediction and Spell Check, 
dictionaries, are stored on the Kurzweil 3000 Web License server as well as 
locally on the Client computer. Upon logging in, Kurzweil 3000 checks both 
locations and uses the latest settings from either location.

Saving a Toolbar Set saves to the Web License server so that others with 
permissions can access the set.
Kurzweil 3000 for Windows Web License Guide 3



Kurzweil 3000 Web License Overview
How Does Web License Work? 

Once your organization completes the Web License product purchase 
process, an IT specialist installs the Web License Client Software, and an 
initial user account is set up by Cambium Learning Customer Service for a 
designated License Coordinator. 

That initial user, who could be a school administrator, IT specialist, even a 
teacher, then creates sub-user accounts for sub-site coordinators at different 
schools, teachers and/or students. At the time of user setup, the system 
generates login information — a username and password — for each user. 

Each user, other than Student users, can set up and manage sub-users 
under his/her account.

To access Kurzweil 3000, log in using the Kurzweil 3000 desktop icon on a 
computer running Web License Client software.

General Web License Edition Notes

Time Out: After 60 minutes of inactivity, a message appears asking if you are 
still using the program. If there is no response, Kurzweil 3000 automatically 
logs off your account. The only function available in Kurzweil 3000 is Save 
so that you can save any work. If there is an assignment in progress, 
Kurzweil 3000 automatically saves the work.
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Chapter 1. Web License Overview, Set Up and Management
Web License System Requirements
Processor: 1.3 GHz Pentium 4 or better

System Memory: 512 MB (1GB for 64-bit Windows Vista or Windows 7)

Hard Disk Space: 2 GB free space

Operating System: Microsoft® XP with Service Pack 3 or later, Windows 
Vista with Service Pack 1 or later, Windows 7

Video RAM: 4 MB or better

Screen Resolution: 1024x768 24-bit or better

Color Palette: 16-bit

DVD drive

Keyboard and mouse 

Sound card with speakers and microphone

TWAIN-compatible scanner 

Internet connection

Web browser: Mozilla Firefox 3.5 or later or Microsoft Internet Explorer 7 or 
later 
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Installing Web License Client Software 
You may need Administrator privilege. 

1. Place the Kurzweil 3000 DVD in the computer’s DVD drive.

2. Double-click the Setup file.

3. In the Master Installation dialog, select Web Licensing Software.

4. Select Install Web Licensing Software.

5. Follow the prompts to finish installing the software. 

6. The system checks for any software updates. If an update is found, you 
can opt to do one of the following:

Choose No to not install the update and have Kurzweil 3000 launch 
normally.

Choose Don't Ask Me Again to not have the system check.

Choose Yes to install the update now. Once the install is complete, 
Kurzweil 3000 launches.

If you do not have administrator privileges, you will be prompted to 
Continue or Cancel. If choosing Continue does not install the update, you 
will need system administrator assistance

7. Restart if prompted to do so.

You are ready to log in to and use Web License Edition by clicking the 
Kurzweil 3000 icon.

Note: 

If you have a 64-bit system, it requires separate installations for the Virtual 
Printer and Taskbar. Both installers are in the x64 folder on the product DVD 
or from ftp://ftp.kurzweiledu.com/pub/x64/.
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Chapter 1. Web License Overview, Set Up and Management
Installing the Web License Client Using the MSI 
Install (IT Professionals)

This option installs the Web License Client computers across your LAN from 
a central location. It is provided for network administrators who are 
knowledgeable about MSI packages and have the necessary tools to operate 
directly on an MSI package.

Microsoft .Net Framework 3.5 must already be installed before using MSI. 

You will need to specify the following arguments as properties to the Kurzweil 
3000 msi package. You must also use the Reduced UI option. 

AUTO= 1 (should be a numeric value)

EDITION= "web"

AUTOUPDATE=0 sets the automatic software update to no updates; using 1 
sets automatic software update to yes

An example to launch Version 13 through command line is as follows:

msiexec.exe  /i "Kurzweil 3000 v.13.msi" AUTO=1 EDITION="web"/qr 
AUTOUPDATE=0 /qr

where /i is the install switch and /qr is the Reduced UI switch.

If the Reduced UI option is not available, you will need an additional MSI, 
found at ftp://ftp.kurzweiledu.com/pub/K3000UIAction/.

Use the second MSI after you finish the first main install.
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Working with User Accounts and License 
Allocation

After your organization purchases a number of Web Licenses, Cambium 
Learning Customer Service sets up the initial user (typically, this is a 
designated site coordinator who could be teacher, school administrator or IT 
specialist). He/she is given username and password for login.

The site coordinator/initial user can then set up the site users, providing them 
with their system-generated usernames and passwords, and allocating 
licenses.

Once that is done, any user can log in, set up, manage and distribute 
licenses to sub-users under their accounts.

Sub-users are typically teachers who set up their own sub-users, typically 
students. Student users, however, do not have User Management access.

Accessing the User Management System

Go to https://accounts.fireflybykurzweil.com and log in. 

Note: From Kurzweil 3000, you can access your firefly account by choosing 
My Account from the File menu. If you need frequent access to this link, 
consider using Tools > Customize Toolbars to place the My Account button 
on a toolbar.
8



Chapter 1. Web License Overview, Set Up and Management
The Home page opens displaying site account information such as the 
number of licenses purchased, allocated and activated.

Along the top, right-hand area are four tabs: Order History, Profile, Users 
and Home. Log Out is in the upper-right-hand corner of the firefly window.

Registering Users

There are two ways to register sub-users under your account:

• You can register each user yourself

• Or set up self-registration so users may self-register
Kurzweil 3000 for Windows Web License Guide 9



Working with User Accounts and License Allocation
To register a user:

1. Click Users to open the main Users page. Note that you also can open 
this page by clicking Register and View Allocated Users.

2. Enter the requested user information. If the user is a student, click the Is 
Student box.Then click Add New.

The user information then appears in the Allocated Users list, along with the 
system-generated username and password. Provide users with their login 
information.

Add New user
10



Chapter 1. Web License Overview, Set Up and Management
To set up for users to self-register:

If you have the proper permissions, you may set up self-registration for your 
sub-users.

1. Click the Users tab (in the top, right-hand corner of the firefly window) to 
open the main Users page.

2. Click User Self-Registration to open the User Self-Registration page.

3. Enter the Number of Licenses for Registration that you want to allot 
for your sub-users.
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Working with User Accounts and License Allocation
4. Click Update.

5. Copy the unique product link and distribute it to your sub-users. This is 
the Internet address that your sub-users can use for self-registration.

To self-register:

1. Obtain the unique product link from your organizations’ license 
coordinator.

2. Paste that link into a Web browser to open the User Self-Registration 
page.

3. Enter your user information.

4. Click Add New.
12



Chapter 1. Web License Overview, Set Up and Management
Viewing and Managing Licenses

To view license information:

1. Click Users to open the main Users page. Note that you also can open 
this page by clicking Register and View Allocated Users.

2. In the Allocated Users area, you can find:

• Total Licenses: the total number of licenses for your site.

• Allocated Licenses: the number of licenses distributed among users.

• Activated Licenses: the number of licenses in use.

• Remaining Licenses: the number of licenses remaining; that is the 
Total Licenses minus the Allocated Licenses.

3. In the list, you can find each user’s limit of licenses allotted, how many of 
those licenses are actively being used by teachers and students. 
Kurzweil 3000 for Windows Web License Guide 13



Working with User Accounts and License Allocation
To set the default number of licenses to allocate to new users:

This is the default number of licenses you want to allocate to each of the sub-
users you add.

1. Click the Users tab to open the main Users page.

2. Click User Self-Registration to open the User Self-Registration page.

3. Enter the Number of Licenses for Registration that you want to allot 
for your sub-users.

4. Click Update.
14



Chapter 1. Web License Overview, Set Up and Management
All new users added subsequent to this update will be allocated the newly set 
number of licenses.

To change license limit for an individual user: 

1. Click the Users tab to open the main Users page.
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Working with User Accounts and License Allocation
2. Click the desired name in the Allocated Users list to open the User 
Information dialog.

3. Change the number in the Teacher Limit box.

4. Click Update Member Information.

Teacher Limit
16
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Managing Users

To delete a user:

1. Click Users to open the main Users page. Note that you also can open 
this page by clicking Register and View Allocated Users.

2. In the Allocated Users list in the main Users page, select the desired 
name, click the Delete X in its row. 

Note: You can use the Manage Removed Users page to view and manage 
deleted users’ information.

To restore deleted users:

1. Click the Users tab to open the main Users page.

2. Click Manage Removed Users.

3. From the Manage Removed Users page, you can Restore a user from 
the list by clicking the Restore icon for that user.
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Working with User Accounts and License Allocation
To change user information, including password:

1. Click the Users tab to open the main Users page.

2. Click the desired name in the Allocated Users list.

Click to open User Information dialog.
18
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3. In the User Information dialog that opens, make the desired changes.

4. Then click Update Member Information.
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Viewing and Changing Your Personal User Information and 
Password

To view and change your own user information, including password:

1. After logging in from any of the following:

From http://fireflybykurzweil.com/, click My Account, then click 
Profile.

Or from https://accounts.fireflybykurzweil.com/, click Profile. 

Or from Kurzweil 3000 File > My Account, click Profile. 
20



Chapter 1. Web License Overview, Set Up and Management
The Profile page includes user information such as address and 
occupation, login, and school/organization information.

2. Make the desired changes.

3. Then click Update Account Information.

Forgot Password?

1. Click the Forgot Password in the log in page.

2. In the Forgot Password? page, enter the email address associated with 
your account.

3. Your username and the original password will be emailed to you.

4. Use the emailed password to log in.

5. Go to and follow the instructions in To view and change your own user 
information above.
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Viewing Order History 

Users (other than students) can check Order History to find details about the 
organization’s licenses, such as, Order Dates, products, licenses and their 
activation/expiration dates. 

To view the Receipt for an order, click the desired order number in the Order 
Number column.

To view the Invoice for an order, click the desired Invoice number in the 
Invoice column.
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2 Web Universal 
Library 

This chapter contains four main sections.

• The Web Universal Library Overview on page 24 has the following 
subsections:

Web Universal Library Structure on page 24.

• Using the Web Universal Library on page 26 has the following 
subsections:

To open a document from the Library: on page 26.

To save an open document to the Library: on page 27.

To create a new folder: on page 28.

To cut, copy, delete, rename a folder or file: on page 29.

To view file properties: on page 30.
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The Web Universal Library Overview
Kurzweil 3000 Web License Edition includes the Web Universal Library. If 
your school uses the Kurzweil 3000 Local Area Network (LAN) Universal 
Library, you are already aware of the benefits of central file storage and 
sharing.

The Kurzweil 3000 Web Universal Library, however, is an expanded version 
of the LAN Universal Library. Because the Web Universal Library is Internet-
based, it allows students and teachers, or any authorized users, using any 
computer running Web License Client software from anywhere on the World 
Wide Web, to access and share files.

For districts and schools, the Web Universal Library is ideal for placing 
standardized curriculum material and print resources in electronic form for all 
or for specific groups to access. Teachers can make class files available 
wherever, whenever students need them.

Included in each Web Universal Library are the following folders: 

• Classic Literature, a collection of nearly 2000 books, historical 
documents selected from the public domain

• Samples, files from Cambium Learning Group's published educational 
series, LANGUAGE!, Learning A-Z and Passport Reading Journeys.

Web Universal Library Structure

The structure of the Universal Library is based on user/sub-user file system 
concept where each authorized user can set up and manage his/her sub-
users.

In addition to sub-user folders, each user also has a Public folder and a 
Private folder. All users have Read-Write permission to his/her own and to 
sub-users’ Public and Private folders

Sub-users only have Read access to the Public folder of the user who 
created their account.

For example, a district could set up folders for each school. In a school's 
folder, there could be folders for teachers as well as a Public and a Private 
24



Chapter 2. Web Universal Library
folder. All teachers and students in the school could access the school’s 
Public folder. Teachers would not be able to access one another’s folders. 

Each teacher folder in turn would have the teacher’s students' folders, plus a 
Public and Private folder. All students whose accounts a teacher creates 
would be able to access their teacher’s Public folder. Students would not be 
able to access one another’s folders.
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Using the Web Universal Library
Using the Web Universal Library
You can open and save to the Universal Library and manage folders and files 
by using either the Open from the Universal Library or Save to the Universal 
Library.

The Web Universal Library currently supports RTF, TXT and KES file 
formats.

To open a document from the Library:

1. From the File menu, choose Open from Library.

2. In the Open from the Universal Library dialog, in the left-hand pane, 
click the folder from which you want to open a file. You may have to open 
subfolders. In the example below a subfolder in the Classic Literature 
folder is selected in the left-hand pane; its content files are listed in the 
right-hand pane., 

3. In the right-hand pane, select the file you want.

4. Click Open.

Notes: 

• No user can save files to the Universal Library Classic Literature folder.

• You can also search for a Classic Literature file by using Online Search; 
for more information, go to online Help.
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Chapter 2. Web Universal Library
To save an open document to the Library:

1. Open the document you want to save to the library.

2. From the File menu, choose Save to Universal Library to open the 
Save to the Universal Library dialog.

3. In the dialog, do the following: 

Specify where you want to place the file by clicking the desired folder in 
the left-hand pane.

(Optional) If you want to create a new folder in which to save this 
document, click the New Folder button in the upper right-hand corner.

(Optional) Change the file name. Note that only lowercase letters, 
numerals and underscores are permitted in file/folder names.

(Optional) Specify another file format.

4. Click Add.

Notes: 

• When saving a file, you are essentially uploading it to the Web server, 
and the time and speed by which a file is uploaded depend on the Internet 
line and service that your site is using. Generally, we recommend 50 
pages or fewer per file, so if you have a rather large text book, it's a good 
idea to separate the chapters and save a chapter at a time.

• No user can save files to the Universal Library Classic Literature folder.
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To create a new folder:

You can only create a new folder under your or your sub-users’ folders.

1. From the File menu, choose either Open from Library or Save to 
Library.

2. In the dialog, in the left-hand pane, click the folder in which you want to 
place the new folder.

3. There are a few places where you can find the New Folder command:

In the left-hand pane, open the Right Mouse Button menu and choose 
New Folder.

In the right-hand pane, open the Right Mouse Button menu and choose 
New Folder.

Or in the upper right-hand corner, click the New Folder button.

4. Type the name of the folder in the Folder Name box that appears. Note 
that only lowercase letters, numerals and underscores are permitted in 
file/folder names.

5. Click Add.
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Chapter 2. Web Universal Library
To cut, copy, delete, rename a folder or file:

Note that you can only cut, copy, delete, rename a folder or file under your or 
your sub-users’ folders. In addition, only lowercase letters, numerals and 
underscores are permitted in file/folder names.

1. From the File menu, choose either Open from Library or Save to 
Library.

2. In the dialog, do one of the following:

For a folder: Select the folder in the left-hand pane.

For a file: First, in the left-hand pane, select the folder in which the file(s) 
are located. Next, select the file(s) from the right-hand pane.

3. Right-click to open the Right Mouse Button menu and choose the 
command you want. The menu below is the File Right Mouse Button 
menu. The Folder menu is similar, but does not have Properties.
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Using the Web Universal Library
To view file properties:

1. From the File menu, choose Open from Universal Library.

2. In the dialog, in the left-hand pane, select the folder in which the file is 
located. Next, select the file from the right-hand pane.

3. Right-click to open the Right Mouse Button menu. Select Properties to 
open the File Properties dialog.

4. Click OK.
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