Clearing the Audio Spooler Queue
This article applies to:
Summary
If you're having problems with the Audio Spooler in Windows, a Technical Support Representative may determine that clearing the pending queue for the Audio Spooler may solve your problem. This document details how to clear the queue.
Symptoms
If you are unable to create an audio file, or the Audio Spooler stays "stuck" with one job permanently listed as the Current Job, you may need to clear the queue. It's best to do this only when advised to by a Technical Support Representative.
Cause
It can sometimes be difficult to pinpoint the cause of this problem. One possible cause is shutting down your machine (or logging off of Windows) while the Audio Spooler is processing a job. Another possible cause is a lack of reliable MP3 compression software on your system.
Solution
If you are using Windows 2000 or Windows XP, open Windows Explorer and navigate to the following path:
- C:\Documents and Settings\All Users\Application Data\KESI\Pending Audio
If you are using Windows 95 or Windows 98, open Windows Explorer and navigate to the following path:
- C:\Windows\All Users\Application Data\KESI\Pending Audio\
In this folder you will find (along with many other things) the two files that control the Audio Spooler queue. These files are named:
- PendingJobs.kms
- CurrentJob.kms
To clear the queue, simply delete these two files. Note that you should only do this after you have rebooted your system, and before you launch Kurzweil 1000 or Kurzweil 3000. Once either of these programs has been run it is unsafe to delete these two files since the Audio Spooler may be accessing them.
Status
This is a known issue that may show up rarely, especially when creating very large audio files. Most users will not experience this problem, so be sure to contact Technical Support before performing this operation.
More Information
Contact Kurzweil Educational Systems' Technical Support for more information.
History
Creation Date: November 7, 2003
Last Modified: November 7, 2003
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