KESI Fax Printer – Unable to Get Filename Error
This article applies to:
- Kurzweil 1000 versions 6 and 7
Symptoms
The KESI Fax Printer provides a convenient mechanism for sending
documents from other applications as faxes. You simply print one or more
pages from the open document, selecting the printer named “KESI Fax”.
This should cause the KESI Fax Application to be run. On some systems,
however, the printer will report an error indicating that it was unable
to get the filename.
Cause
The KESI Fax printer needs to know the full path of the KESI Fax
Application. The error occurs when it cannot find that application.
Solution
There are two
procedures, depending upon which operating system you are using.
If your operating
system is Windows ’95, Windows ’98, or Windows ME, you should contact
customer support and ask them to send you FixKesiFax.exe. When you
receive this application, run it. It will display a short message. Press enter, and it will repair this problem,
modifying the file win.ini.
The remainder of this
article will describe a procedure that you should follow for Windows XP,
Windows 2000, or Windows NT. Note that this procedure was tested
primarily on Windows XP. You may have to adjust it slightly for the
other operating systems.
Use the Windows key
to bring up the Start dialog, and move around with arrow keys until you
find "Printers and Faxes". Press enter.
Use down arrow until you select the "Kesi
Fax" printer. At that point, press ALT, then "F", then "R", to open the
properties dialog for that printer.
Press Control+Tab until you get to the
Ports screen. You will be in a list of possible ports. This list has
check boxes before each item in the list. Only one of the items should
be checked. It should read something like the following:
KESI... DataTech FAX Port Kesi Fax
If this is not the only checked item, or it isn't checked, then you
should fix that. It should be the only item checked.
Once it is selected, tab to the Configure Port
button, and press enter.
The first control in the Configure Fax Port
dialog will be a text box labeled Application. Its contents should be
something like the following:
C:\Program Files\Kurzweil Educational Systems\Kurzweil
1000\Apps\KFax.exe
Record the contents of that field.
Tab to the Browse button, and press enter. This will bring up something
like a common file dialog. You will be positioned at a blank text box
labeled File Name. Press Shift plus Tab to get to the list of items in
the current folder. That list should contain Copier.exe, and KFax.exe.
If it doesn't, you have identified your problem.
Doing whatever one does with this kind of dialog and a screen reader,
find the location of KFax.exe, select it, and press enter. Tab to the OK
button, and press it. Do that again, for the parent dialog. Eventually
you'll be done.
Status
We expect to address the cause of the problem for Windows 95,
Windows 98, and Windows NT in the next full release of the Kurzweil
1000. The cause for other operating systems seems to have more to do
with clients modifying their printer properties, which is something we
cannot protect against.
History
Creation Date: March 28, 2003
Last Modified: March 28, 2003
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