Kurzweil Educational Systems logo link to home page

  Find us on Facebook
Follow us on Twitter

Kurzweil 3000 Version 12 |  Kurzweil 3000 |  Kurzweil 1000

Can't Access Universal Library Across the Network


This article applies to:

  • Kurzweil 3000 for Windows, versions 4.0 through 7.0


Summary

If you set up the Universal Library on a Windows NT-based system (Windows NT 4.0, Windows 2000, or Windows XP Home and Professional Editions) using the ServerLibraryWizard utility, you may not be able to access it from other machines on the network.

Symptoms

See the "Summary" description above.

Cause

Under Windows NT, 2000, and XP, a folder is created and "shared" using the Windows Sharing service.  These operating systems require a security descriptor which is not created by the ServerLibraryWizard.

Solution

To fix this problem you need to manually add a security descriptor for this folder for the "Everyone" user group.  You can do this as follows:

  • Launch Windows Explorer by holding down the Windows key on your keyboard while pressing the letter "E".
  • In the left pane of Windows Explorer, single left-click on the folder "C:\Kurzweil 3000 Universal Library".
  • In Windows Explorer, click the “Tools” menu and select “Folder Options…”.  In the dialog that appears click the “View” tab.
  • Scroll to the bottom of the "Advanced settings" list and make sure the “Use simple file sharing (Recommended)” item is NOT checked, and click “OK”.
  • In the left pane of Windows Explorer, right-click on the folder "C:\Kurzweil 3000 Universal Library".  Select “Sharing and Security…” from the menu that pops up.
  • On the “Kurzweil 3000 Universal Library Properties”dialog that appears, click the “Security” tab.  Click the “Add…” button on the security tab and another dialog will appear.
  • In the white box under "Enter the object names to select (examples):", type the word "Everyone" exactly as it appears here and click "OK".
  • Back in the “Kurzweil 3000 Universal Library Properties” dialog, under “Permissions for Everyone”, check the “Allow” box next to “Full Control” and click “OK”.
  • Click "OK" in the remaining open dialog.

Status

The current solution to this problem is to use the workaround described above.

More Information

This is not an issue if the machine on which you created the Universal Library is running Windows 95, 98, 98 SE, or ME.  The version of Windows used by the client machines is also not an issue, only the machine housing the Universal Library..

History

Creation Date: April 11, 2003

Last Modified: April 11, 2003



If you can't find what you are looking for here on our knowledge base, please visit our Frequently Asked Questions section.

 

  Cambium Learning