System Requirements

Kurzweil 1000 requires a TWAIN or WIA-compatible flatbed scanner, and a computer that meets or exceeds the system requirements listed below:

Kurzweil 1000 does not currently support thin-client based environments as it was not designed for some of the special requirements of these systems.